LinuxSay - A Discussion Forum for Linux Enthusiasts

Apache not working with PHP5 on Ubuntu 14.04


#1

I have just installed LAMP server on Ubuntu 14.04 for a friend, it has worked well but there is a problems with PHP5. I tried to test the working of PHP5 using the info.php in my root directory. When i try to load it from the web browser it failed to work. I also used another php script still it has failed to work.

What could be the problem?


#2

@aaronkili45

what is the issue and what did you found in log files


#3

The content of .php files can not be displayed from the browser.


#4

can you please share the snap shot and also once check the version of php

#php -v

#5

Here is the output:


#6

once look at your apache configuration file whether php interpreter is commented or not.

vim /etc/httpd/conf.d/php.conf

if it is commented uncomment it and restart the apache server


#7

Thanks for helping, i just had to the run the command below and it helped:

# apt-get install libapache2-mod-php5*

and it has worked.