How to Install VLC Media Player in CentOS 6.6


#1

When i tried to install VLC media player in my centos 6.6 system, I am getting following problem. please help

# yum install --nogpgcheck http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-7.noarch.rpm
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Cannot open: #http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-7.noarch.rpm. Skipping.
Error: Nothing to do

#2

@sravan

I see the EPEL repository you’re trying to install VLC was not available and getting not found error, it seems that the package was removed, try to use the newest epel repo version as suggested below.

# # yum install --nogpgcheck http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm

I hope it will work for you…


#3

thanks for your reply,
I tried your sample but still i am getting same issue.

yum install --nogpgcheck http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
Loaded plugins: fastestmirror, refresh-packagekit, security
Setting up Install Process
Cannot open: #http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm. Skipping.
Error: Nothing to do

Thanks


#4

hello sravan!

have u tried the NUX repo?!?! i recommend for u.


#5

Hi dzsolly85,
Thanks for your reply, I tried below command.
yum --enablerepo=nux-dextop install vlc

and i got following error

–> Finished Dependency Resolution
Error: Package: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: libgmp.so.10()(64bit)
Error: Package: librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64 (nux-dextop)
Requires: libgnutls.so.28(GNUTLS_1_4)(64bit)
Error: Package: ffmpeg-compat-0.6.7-9.el7.nux.x86_64 (nux-dextop)
Requires: libgmp.so.10()(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libchromaprint.so.0()(64bit)
Error: Package: gstreamer-plugins-bad-0.10.23-5.el7.nux.x86_64 (nux-dextop)
Requires: libgmp.so.10()(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libgnutls.so.28()(64bit)
Error: Package: libcddb-1.3.2-12.el7.nux.x86_64 (nux-dextop)
Requires: libcdio.so.15()(64bit)
Error: Package: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: libgnutls.so.28()(64bit)
Error: Package: libavdevice-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: libcdio_paranoia.so.1()(64bit)
Error: Package: zvbi-0.2.33-16.el7.nux.x86_64 (nux-dextop)
Requires: libpng15.so.15()(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libass.so.5()(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libmtp.so.9()(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libpng15.so.15()(64bit)
Error: Package: gstreamer-plugins-bad-0.10.23-5.el7.nux.x86_64 (nux-dextop)
Requires: libgnutls.so.28()(64bit)
Error: Package: libquicktime-1.2.4-19.el7.nux.x86_64 (nux-dextop)
Requires: libpng15.so.15()(64bit)
Error: Package: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: liblzma.so.5()(64bit)
Error: Package: zvbi-0.2.33-16.el7.nux.x86_64 (nux-dextop)
Requires: libpng15.so.15(PNG15_0)(64bit)
Error: Package: vlc-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libz.so.1(ZLIB_1.2.3.3)(64bit)
Error: Package: gstreamer-plugins-bad-0.10.23-5.el7.nux.x86_64 (nux-dextop)
Requires: gstreamer-plugins-bad-free >= 0.10.23
Installed: gstreamer-plugins-bad-free-0.10.19-3.el6_5.i686 (@base)
gstreamer-plugins-bad-free = 0.10.19-3.el6_5
Error: Package: libquicktime-1.2.4-19.el7.nux.x86_64 (nux-dextop)
Requires: libpng15.so.15(PNG15_0)(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libva.so.1(VA_API_0.33.0)(64bit)
Error: Package: libavdevice-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: libcdio_cdda.so.1(CDIO_CDDA_1)(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libva-drm.so.1()(64bit)
Error: Package: libavdevice-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: libcdio_cdda.so.1()(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libmatroska.so.6()(64bit)
Error: Package: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: liblzma.so.5(XZ_5.0)(64bit)
Error: Package: zvbi-0.2.33-16.el7.nux.x86_64 (nux-dextop)
Requires: systemd-units
Error: Package: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: libgnutls.so.28(GNUTLS_1_4)(64bit)
Error: Package: vlc-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: qt4(x86-64) >= 4.8.5
Installed: 1:qt-4.6.2-28.el6_5.x86_64 (@base)
qt4(x86-64) = 4.6.2-28.el6_5
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libgnutls.so.28(GNUTLS_1_4)(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libebml.so.4()(64bit)
Error: Package: libcddb-1.3.2-12.el7.nux.x86_64 (nux-dextop)
Requires: libcdio.so.15(CDIO_15)(64bit)
Error: Package: x265-libs-1.6-1.el7.nux.x86_64 (nux-dextop)
Requires: libm.so.6(GLIBC_2.15)(64bit)
Error: Package: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: libass.so.5()(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libudev.so.1()(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libudev.so.1(LIBUDEV_183)(64bit)
Error: Package: gstreamer-plugins-bad-0.10.23-5.el7.nux.x86_64 (nux-dextop)
Requires: gstreamer >= 0.10.33
Installed: gstreamer-0.10.29-1.el6.i686 (@base)
gstreamer = 0.10.29-1.el6
Error: Package: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: libopenjpeg.so.1()(64bit)
Error: Package: ffmpeg-libs-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: libgnutls.so.28(GNUTLS_3_0_0)(64bit)
Error: Package: librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64 (nux-dextop)
Requires: libgnutls.so.28(GNUTLS_2_12)(64bit)
Error: Package: librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64 (nux-dextop)
Requires: libgnutls.so.28()(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libgnutls.so.28(GNUTLS_3_0_0)(64bit)
Error: Package: libavdevice-2.6.3-1.el7.nux.x86_64 (nux-dextop)
Requires: libcdio_paranoia.so.1(CDIO_PARANOIA_1)(64bit)
Error: Package: ffmpeg-compat-0.6.7-9.el7.nux.x86_64 (nux-dextop)
Requires: libopenjpeg.so.1()(64bit)
Error: Package: vlc-core-2.2.1-6.el7.nux.x86_64 (nux-dextop)
Requires: libpng15.so.15(PNG15_0)(64bit)
Error: Package: lirc-libs-0.9.0-21.el7.nux.x86_64 (nux-dextop)
Requires: libsystemd-daemon.so.0()(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


#6

sravan

updated when left in front of the repositroy ?!
what kind repositories have you?! example: elrepo, epel etc…


#7

Hello dzsolly85,

I am using epel repository,
I am getting same error while updating also
“yum update”
Thanks

$ yum repolist
Loaded plugins: fastestmirror, refresh-packagekit, security
Determining fastest mirrors
epel/metalink | 4.2 kB 00:00

  • base: centos.excellmedia.net
  • epel: epel.mirror.net.in
  • extras: centos.excellmedia.net
  • remi-safe: mirrors.thzhost.com
  • rpmforge: mirror.oscc.org.my
  • rpmfusion-free-updates: mirror.smartmedia.net.id
  • rpmfusion-nonfree-updates: mirror.smartmedia.net.id
  • updates: centos.excellmedia.net
    adobe-linux-x86_64 | 951 B 00:00
    adobe-linux-x86_64 2/2
    base | 3.7 kB 00:00
    chromium-el6 | 1.9 kB 00:00
    extras | 3.4 kB 00:00
    pgdg94 | 3.7 kB 00:00
    remi-safe | 2.9 kB 00:00
    remi-safe/primary_db | 219 kB 00:00
    rpmforge | 1.9 kB 00:00
    rpmfusion-free-updates | 2.7 kB 00:00
    rpmfusion-nonfree-updates | 2.2 kB 00:00
    updates | 3.4 kB 00:00
    repo id repo name status
    adobe-linux-x86_64 Adobe Systems Incorporated 2
    base CentOS-6 - Base 6,560+15
    chromium-el6 CentOS-6 - Chromium EL6 8
    epel Extra Packages for Enterprise Linux 6 - x86_6 11,874
    extras CentOS-6 - Extras 45
    google-chrome google-chrome 3
    pgdg94 PostgreSQL 9.4 6 - x86_64 307
    remi-safe Safe Remi’s RPM repository for Enterprise Lin 510
    rpmforge RHEL 6 - RPMforge.net - dag 4,718
    rpmfusion-free-updates RPM Fusion for EL 6 - Free - Updates 293
    rpmfusion-nonfree-updates RPM Fusion for EL 6 - Nonfree - Updates 87
    updates CentOS-6 - Updates 644+26
    repolist: 25,051

#8

sravan

I see quite a lot of storage is above.
I know that some stores have to collide with each other.
I recommend that the remi repositories, rpmforge and rpmfusion turn it off and instead just use the Nux container.
the other storage remain unchanged.
CentOS sensitive when several devices are activated simultaneously.

…and then yum update. :smile:


#9

Hello dzsolly85
I have disabled all those repositories.
my problem was almost solved, but when I update I’m getting below error

–> Finished Dependency Resolution
Error: Package: gstreamer-plugins-bad-0.10.19-3.el6.rf.x86_64 (@rpmforge)
Requires: libmpeg2encpp-1.9.so.0()(64bit)
Removing: mjpegtools-1.9.0-1.el6.rf.x86_64 (@rpmforge)
libmpeg2encpp-1.9.so.0()(64bit)
Updated By: mjpegtools-2.0.0-4.el6.x86_64 (rpmfusion-free-updates)
Not found
Error: Package: gstreamer-plugins-bad-0.10.19-3.el6.rf.x86_64 (@rpmforge)
Requires: libmjpegutils-1.9.so.0()(64bit)
Removing: mjpegtools-1.9.0-1.el6.rf.x86_64 (@rpmforge)
libmjpegutils-1.9.so.0()(64bit)
Updated By: mjpegtools-2.0.0-4.el6.x86_64 (rpmfusion-free-updates)
Not found
Error: Package: gstreamer-plugins-bad-0.10.19-3.el6.rf.x86_64 (@rpmforge)
Requires: libmodplug.so.0()(64bit)
Removing: libmodplug-0.8.7-1.el6.rf.x86_64 (@rpmforge)
libmodplug.so.0()(64bit)
Updated By: 1:libmodplug-0.8.8.5-1.el6.x86_64 (epel)
Not found
Error: Package: libquicktime-1.2.4-1.el6.rf.x86_64 (@rpmforge)
Requires: libx264.so.107()(64bit)
Removing: x264-0.0.0-0.4.20101111.el6.rf.x86_64 (@rpmforge)
libx264.so.107()(64bit)
Updated By: x264-0.120-5.20120303.el6.x86_64 (rpmfusion-free-updates)
Not found
Error: Package: gstreamer-plugins-bad-0.10.19-3.el6.rf.x86_64 (@rpmforge)
Requires: libmplex2-1.9.so.0()(64bit)
Removing: mjpegtools-1.9.0-1.el6.rf.x86_64 (@rpmforge)
libmplex2-1.9.so.0()(64bit)
Updated By: mjpegtools-2.0.0-4.el6.x86_64 (rpmfusion-free-updates)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


And my repolist

yum repolist
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile

  • base: centos.excellmedia.net
  • epel: epel.mirror.net.in
  • extras: centos.excellmedia.net
  • rpmfusion-free-updates: kartolo.sby.datautama.net.id
  • updates: centos.excellmedia.net
    repo id repo name status
    base CentOS-6 - Base 6,560+15
    chromium-el6 CentOS-6 - Chromium EL6 8
    epel Extra Packages for Enterprise Linux 6 - x86_64 11,823
    extras CentOS-6 - Extras 48
    google-chrome google-chrome 3
    pgdg94 PostgreSQL 9.4 6 - x86_64 310
    rpmfusion-free-updates RPM Fusion for EL 6 - Free - Updates 294
    updates CentOS-6 - Updates 928+26

#10

Thank you dzsolly85, my problem was solved.

I have also disabled rpmfusion-free-updates.repo, and removed gstreamer-plugins-bad-0.10.19-3.el6.rf.x86_64 using

yum remove gstreamer-plugins-bad-0.10.19-3.el6.rf.x86_64
and I successfully updated my centos.

Thanks for your help.


#11

hello sravan.

i dont know what is the problem but i see something strange in ur repolist.

(@rpmforge); (rpmfusion-free-updates)

those repos maybe conflict eachother!

disable the rpmforge repo is u can.


#12

ohhh it was quickly! :smiley:

not at all!

:smiley:


#13

i used cent os with three or four repos.
elrepo, epel, nux, or rpmfusion.

some repo is “black” for me.

like artpms, rpmforge etc.


#14

hi,
while installing some packages i also found some of the errors like

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

my doubt is whats does that line means and also what does the line tells rpm -Va --nofiles --nodigest, can any one explain what the line means!!!

and i also tried by adding the flags like nodigest and nofiles, nothing had happened, for what it is used for???


#15

@msp_surya

Have you gone through our latest article on VLC? If not, just go through it and install VLC on CentOS 6.6 as instructed in this article.

http://www.tecmint.com/install-vlc-media-player-in-rhel-centos-fedora/


#16

thanks for ur response @ravisaive, i dont have problem in VLC player. but at the time of some packge installation i am alse geting this kind of errors, i dont know what does it means , so want to know about what does this lines means

You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest.

can u plz explain what does this line says.


#17

@msp_surya

Could you post the whole yum output here, so that we can better understand your problem…