Install mod_pagespeed on centos 6 with apache 2.4


#1

Hi guys,

Im having difficulties install mod page speed on centos 6 with apache 2.4

My /etc/yum.repos.d/google-mode-pagespeed.repo has

[google-mod-pagespeed]
      2 name=google-mod-pagespeed
      3 baseurl=http://dl.google.com/linux/mod-pagespeed/rpm/stable/$basearch
      4 enabled=1
      5 gpgcheck=0

and when I do yum install mod-pagespeed, it gives:

Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.webhost.net
 * epel: ftp.webhost.nl
 * extras: mirror.webhost.net
 * remi: nl.mirror.webhost.network
 * remi-safe: nl.mirror.webhost.network
 * updates: mirror.webhost.net
Resolving Dependencies
--> Running transaction check
---> Package mod-pagespeed-beta.x86_64 0:1.11.33.4-0 will be installed
--> Processing Dependency: httpd >= 2.2 for package: mod-pagespeed-beta-1.11.33.4-0.x86_64
--> Finished Dependency Resolution
Error: Package: mod-pagespeed-beta-1.11.33.4-0.x86_64 (google-mod-pagespeed)
           Requires: httpd >= 2.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

My apache

    httpd -v 
    Server version: Apache/2.4.18 (Unix)
    Server built:   Jul 17 2016 16:07:43
    Cpanel::Easy::Apache v3.34.1 rev9999

Seems like it is expecting to have apache 2.2, but I dont see why it should not work with 2.4

Please help

thanks


#2

Hi

Do one thing download rpm file, install it

#wget https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-stable_current_x86_64.rpm

#rpm -Uvh mod-pagespeed-stable_current_x86_64.rpm

#3

Result is:
warning: mod-pagespeed-stable_current_x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY
error: Failed dependencies:
httpd >= 2.2 is needed by mod-pagespeed-stable-1.11.33.4-0.x86_64