Kerboros client asking for password after getting tgt ticket. I have checker all conf. But still asking password while ssh


#1

I have enabled Gssapi successful kerberos user can be login with kerberos password. While ssh server from client its ask for password.


#2

Hi

You can use -v for debugging during the ssh connection.

$ssh -v kdc.foobar.com

and also you have to enable GSSAPI Auth on both client and server, and here it seems like you are try on the same server, do one thing try to trigger out the issue using -v


#3

I enabled GSSAPI on both server and client. When I do kinit username on client its works TGT is fetching from server. When I do ssh -v user@server.com still asks for pass. Time and name resolution also correct.


#4

what is the out put of above command and also try

#ssh -vv kdc.foobar.com

here–

-v is verbose

which gives the details info during the ssh connection and by going through that output we can diagnosis the issue