Nagios not working in my centos 6.7?


#1

I have installed nagioscore-nagios-4.1.1 & nagios-plugins-2.1.1, all the services & configuration are configured good, and service also started good.

When I hit into the Web below error I got

For Your Information see the below screen shot !!!


#2

Hi,

Above mentioned command shows that config file is ok.

try to run “ps fax | grep -i nagios” to check that process is running, if it is running, then there is issue with web configuration.


#3

I think the error you getting because of SELinux, try to disable it or add SELinux context rule to apache to allow Nagios to run…


#4

I have done already, but not working ??? why I dont know

[root@localhost ~]# ps fax | grep -i nagios
3172 pts/0 S+ 0:00 _ grep -i nagios
3157 ? Ss 0:00 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
3159 ? S 0:00 _ /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
3160 ? S 0:00 _ /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
3161 ? S 0:00 _ /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
3162 ? S 0:00 _ /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
3163 ? S 0:00 _ /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
3164 ? S 0:00 _ /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
3165 ? S 0:00 _ /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
[root@localhost ~]# getenforce
Disabled
[root@localhost ~]# /etc/init.d/nagios status
nagios (pid 3157) is running…
[root@localhost ~]# /etc/init.d/httpd status
httpd (pid 3083) is running…
[root@localhost ~]#


#5

I think all the services are running fine but not able to view in web I dont know why ??


#6

You need to try to install php package and then try again…


#7

I request you to check the Apache server logs, it seems the issue is related to your Apache configuration. Could you please check the logs and post the error here, so that we can get better idea about you problem…


#8

Yes you are right, I have removed the nagios and re-configured it successfully using below link, but not able to login the password is not accepting.

http://www.tecmint.com/install-nagios-in-linux/

  1. How to remove the existing user in nagios
  2. how to reset the password
  3. how to add the new user.

Please advice thanks in advance


#9


#10

Thanks !! I have resolve the issue by reset the Nagios Password Rockssss


#11

Hi

You can reset the password for the existing user by using the below command, the below command will update the file called htpasswd.users

# htpasswd /usr/local/nagios/etc/htpasswd.users nagiosadmin

if you want to recreate the existing file then use -c

htpasswd -c /usr/local/nagios/etc/htpasswd.users nagiosadmin


#12

@raghuu and @dhanupreeth

Take a moment to introduce yourself here Welcome! Introduce yourself here!