Nrpe plugin error on linux host


#1

Hi All,

I try to install NRPE on Centos 7 Machine reference(http://www.tecmint.com/how-to-add-linux-host-to-nagios-monitoring-server/) but i am getting error .

[root@tecmint nrpe-3.0]# cd nrpe-3.0
[root@tecmint nrpe-3.0]# ./configure
[root@tecmint nrpe-3.0]# make all
[root@tecmint nrpe-3.0]# make install-plugin
[root@tecmint nrpe-3.0]# make install-daemon
all things are ok
Now run
[root@tecmint nrpe-3.0]# make install-daemon-config
Error :-
make: *** No rule to make target install-daemon-config'. Stop. [root@ip-172-31-5-83 nrpe-3.0]# make install-xinetd Error :- make: *** No rule to make targetinstall-xinetd’. Stop.

If any one know the solution.So please update ASAP

Thanks


#2

Instead of compiling and installing, install epel repository and then install NRPE plugin

For installing EPEL repo

# yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

For installing NRPE

# yum install nrpe nagios-plugins-users nagios-plugins-load nagios-plugins-swap nagios-plugins-disk nagios-plugins-procs 

#3

Hello NITIN_SHRIVASTAV,
Here is how to do this:

yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

Install NRPE and the plugins that is required to add the services via the function “Add UNIX client services” when adding a new host in the configuration UI in op5 Monitor


yum install nrpe nagios-plugins-users nagios-plugins-load nagios-plugins-swap nagios-plugins-disk nagios-plugins-procs


Configure the agent to utilize the plugins using commands supported by op5 Monitor host scan.

Create a new file called /etc/nrpe.d/op5_commands.cfg containing the following information:

-################################################################################

op5-nrpe command configuration file

COMMAND DEFINITIONS

Syntax:

command[<command_name>]=<command_line>

command[users]=/usr/lib64/nagios/plugins/check_users -w 5 -c 10
command[load]=/usr/lib64/nagios/plugins/check_load -w 15,10,5 -c 30,25,20
command[check_load]=/usr/lib64/nagios/plugins/check_load -w 15,10,5 -c 30,25,20
command[swap]=/usr/lib64/nagios/plugins/check_swap -w 20% -c 10%
command[root_disk]=/usr/lib64/nagios/plugins/check_disk -w 20% -c 10% -p / -m
command[usr_disk]=/usr/lib64/nagios/plugins/check_disk -w 20% -c 10% -p /usr -m
command[var_disk]=/usr/lib64/nagios/plugins/check_disk -w 20% -c 10% -p /var -m
command[zombie_procs]=/usr/lib64/nagios/plugins/check_procs -w 5 -c 10 -s Z
command[total_procs]=/usr/lib64/nagios/plugins/check_procs -w 190 -c 200
command[proc_named]=/usr/lib64/nagios/plugins/check_procs -w 1: -c 1:2 -C named
command[proc_crond]=/usr/lib64/nagios/plugins/check_procs -w 1: -c 1:5 -C crond
command[proc_syslogd]=/usr/lib64/nagios/plugins/check_procs -w 1: -c 1:2 -C syslog-ng
command[proc_rsyslogd]=/usr/lib64/nagios/plugins/check_procs -w 1: -c 1:2 -C rsyslogd

Now edit /etc/nagios/nrpe.cfg and add your Monitor server(s) address(es) to the allowed_hosts parameter as a comma-separated list, example:


allowed_hosts=127.0.0.1,10.0.0.10,10.0.0.11

Restart the nrpe agent on the host, and make sure that nrpe is started at boot:

systemctl restart nrpe

systemctl enable nrpe

Best Regards.