LinuxSay - A Discussion Forum for Linux Enthusiasts

Apache server is not working in mint linux 17.2

Hi Team,

I install mint linux 17.2 , and i install apache server lamp.

. i cearte database 1
import the .sql file.
my drupla file i
placed va/www path.
http://localhost/lastinfo02/
home page is came
but when i click any tab,menu,node then showing like this.

Not Found
The requested URL /lastinfo02/content/deepika was not found on this server.
Apache/2.4.7 (Ubuntu) Server at localhost Port 80

please help me

Thanks,
Sabbul

your URL syntax is incorrect

the correct syntax is

http://localhost/lastinfo02/content/deepika

OR

http://127.0.0.1/lastinfo02/content/deepika

If this won`t work reconfigure your apache2 server

Could you show your apache conf file, should be in folder /etc/apache2/sites-enabled/
Also did you create a database user and give it rights for the database, matching the settings in drupal/sites/default/settings.php ?
You might also need to make rewrite rules in apache conf to use URI:s without ‘?’ parameter.
Something like this:

<Directory /var/www/>
  AllowOverride all
  RewriteEngine on

<IfModule mod_rewrite.c>
 RewriteEngine on
 RewriteCond %{HTTP_HOST} ^(.+\..+)$ [NC]
 RewriteCond %{HTTP_HOST} !^.+\..+\..+$ [NC]
 RewriteRule ^(.*)$ http://www.%1/$1 [L,R=301]
 RewriteCond %{HTTP_HOST} ^(.*)$ [NC]
 RewriteRule ^files/(.*)$ sites/%1/files/$1 [L]
 RewriteRule ^files/(.*)$ sites/%1/files/$1 [L]
 RewriteCond %{REQUEST_FILENAME} !-f
 RewriteCond %{REQUEST_FILENAME} !-d
 RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
 </IfModule>
</Directory>