Can anyone assist setting up a network printer on Centos 7?

Hello,
I am having a difficulty setting up a network printer. The same printer (has an IP) works fine with Centos 6 and Windows. I tried to setup via GUI Printer setting. Ports for ipp, snmp, http/s ssh, nfs are currently enabled. Not sure this has something to do with Nagios, but disabling Nagios didn’t help. /var/log/messages show something like “Failed to mark scope session-12518.scope as abandoned : Stale file handle”. Does anyone have an idea of how to successfully set up a network printer on Centos 7?
Any help will be much appreciated.
Regards,
Momo

@Momo

Hi Upgrading systemd to 208-20.el7 or later will fix the issue.

#yum update systemd-208-20.e17

Actually this behaviour is caused by a bug.

Thank you for the response. I have tried to update the systemd.

# systemctl --version
  systemd 208

Installed Packages
systemd.x86_64                               208-20.el7_1.6                               @updates

The printer got added successfully, but the queue gets till stuck. I’ll dig more into it.
Thanks.
Momo

You can clean all those jobs manually

#lpq

it will list all the jobs in queue

#cancel -u user

You can cancel only jobs owned by you, or by an specified user

#cancel -a printer

(or)

#cancel (printerjobid)

otherwise you can clean all those queues by openig the cups web browser interface

http://localhost:631/printers

1 Like

Well, the question was not about how to clean queues, but you gave me an idea of using a command utility to administer printers. Thank you very much for the prompt assistance. It helped a lot!