Can CentOS 5.0 support kernel 3.14 or newer

In your article, you said CentOS 6.0+ can test kernel 3.5 successfully. I have a server which runs on CentOS 5.0, and for some reason, i need updated the kernel to 3.14 or newer, can i updated the kernel directly on CentOS 5.0?

who can talk about the relationship between issues and kernels. please help me
Thanks a lot.

The best idea would be for you to try it in a virtual machine environment. If it works then you can update on your real server.
Many users have upgraded to latest versions of CentOS, therefore they may not have tried what you exactly need.

@yangshu

Hi yanghu its better to install latest kernel (wht do you want) instead of upgrading kernel, if you face any issue with newly installed kernel then you have chance to bootup your server by shifting it to previous kernel (old kernel).

Thank you for your advice, i have tried to updated kernel directly, but failed.

Yes, i tried to install the 3.14 kernel, but failed.

@yangshu

Could you please share how you tried to update the kernel? via yum or source? is there any errors you get while updating kernel? the more information your provide the more easier for us to understand and help you…

I update the kernel via make source and use SSH to connect to the Server. i almost follow the steps in the article “http://www.tecmint.com/kernel-3-5-released-install-compile-in-redhat-centos-and-fedora/”. But when i make for after half an hour, it has following errors:

CHK include/linux/version.h
CHK include/generated/utsrelease.h
CALL scripts/checksyscalls.sh
CHK include/generated/compile.h
HOSTCC samples/hidraw/hid-example
In file included from /usr/include/sys/time.h:31,
from /usr/include/linux/input.h:12,
from samples/hidraw/hid-example.c:14
/usr/include/sys/select.h:78: error: conflicting types for 鈥榝d_set鈥
/usr/include/linux/types.h:12: error: previous declaration of 鈥榝d_set鈥was here
In file included from /usr/include/linux/input.h:14,
from samples/hidraw/hid-example.c:14:
/usr/include/sys/types.h:62: error: conflicting types for 鈥榙ev_t鈥
/usr/include/linux/types.h:13: error: previous declaration of 鈥榙ev_t鈥was here
/usr/include/sys/types.h:67: error: conflicting types for 鈥榞id_t鈥
/usr/include/linux/types.h:27: error: previous declaration of 鈥榞id_t鈥was here
/usr/include/sys/types.h:72: error: conflicting types for 鈥榤ode_t鈥
/usr/include/linux/types.h:15: error: previous declaration of 鈥榤ode_t鈥was here
/usr/include/sys/types.h:77: error: conflicting types for 鈥榥link_t鈥
/usr/include/linux/types.h:16: error: previous declaration of 鈥榥link_t鈥was here
/usr/include/sys/types.h:82: error: conflicting types for 鈥榰id_t鈥
/usr/include/linux/types.h:26: error: previous declaration of 鈥榰id_t鈥was here
In file included from /usr/include/sys/types.h:133,
from /usr/include/linux/input.h:14,
from samples/hidraw/hid-example.c:14:
/usr/include/time.h:105: error: conflicting types for 鈥榯imer_t鈥
/usr/include/linux/types.h:22: error: previous declaration of 鈥榯imer_t鈥was here
In file included from /usr/include/linux/input.h:14,
from samples/hidraw/hid-example.c:14:
/usr/include/sys/types.h:235: error: conflicting types for 鈥榖lkcnt_t鈥
/usr/include/linux/types.h:114: error: previous declaration of 鈥榖lkcnt_t鈥was here
samples/hidraw/hid-example.c: In function 鈥榖us_str鈥
samples/hidraw/hid-example.c:171: error: 鈥楤US_VIRTUAL鈥undeclared (first use in this function)
samples/hidraw/hid-example.c:171: error: (Each undeclared identifier is reported only once
samples/hidraw/hid-example.c:171: error: for each function it appears in.)
make[2]: *** [samples/hidraw/hid-example] Error 1
make[1]: *** [samples/hidraw] Error 2

@yangshu

what is your O.S version is it 32 bit or 64 bit.

and also i found some info regarding this issue once look at this it might help you.

Go back into your kernel config

#make menuconfig
and uncheck several boxes in the Kernel Hacking section. Start by unchecking “Sample kernel code” stuff, and if that doesn’t work, uncheck the box for “Build targets in Documentation/ tree”. I think it’s the former item, though, because it’s code in the samples/ directory that isn’t building. I’ll only assume that the regular kernel code built just fine.
1 Like

Hi raghuu,

My version is 32 bit, and I followed your advice-- Start by unchecking "Sample kernel code " stuff, and it compiled well, and i even successfully install 3.2 kernel. However , After i modify the grub.conf to set default to 0 in order to enter the new kernel, it broke up when loading the module during reboot. So I reinstall the CentOS 6.5.

Very appreciated your help.

@yangshu

Finally you installed kernel Good to hear such words, and why are reinstalling the O.S instead of reinstalling try to boot up the machine using old kernel any how while installing O.S use 64 bit.

Because i can’t enter the old kernel, so i have to reinstall the system CentOS 6.5. But i still have to updated the kernel. do you know how to boot up the machine using old kernel if failed to boot up in the new kernel.

annotation the “hiddenmenu” in the menu.lst can solve it?

After i reinstall the CentOS6.5, I successfully installed the 3.17.1 kernel, thanks all of you!