CPU fan can't be detected. Motherboard sensors detection problem

Hi friends.
By all means I am unable to ensure that my CPU fan works well because it cannot be detected by /proc/cpuinfo, dmidecode, sensors, various ACPI fan scripts etc. My laptop sometimes hangs and then shuts down and then gets stuck at boot with black screen. But this happens sometimes. I am of the view that my CPU fan does not function properly and on detecting high temperature it shuts down. So far I have come to the conclusion that there is lack of support from ACPI on my Acer Aspire V5 571G. Another problem I face is my laptop gets stuck in shutdown-reboot loop be it Kali Linux, be it Ubuntu. Any idea to get around this folks?

I am using Ubuntu 14.04.02 on Acer Aspire V5 571G.

I have followed millions of links like:
https://www.linux.com/learn/tutorials/620416:discovering-and-monitoring-hardware-in-linux-
https://help.ubuntu.com/community/AspireOne/AOA150
http://ubuntuforums.org/showthread.php?t=1612786

@eralbert9191,
I am assuming that your assumption of the shutdown being caused by a high temperature is supported by facts - meaning you’ve felt an increase of temperature in the external case, etc.
Have you tried resetting your firmware settings (BIOS or (U)EFI) to default? Last but not least, boot from a LiveDVD/USB with Debian (note that I am saying Debian and not one of its derivatives like Ubuntu) - then get back to us and tell us if you’re still experiencing the shutdown-reboot loop.
Look forward to hearing from you.

Thanks a lot @gacanepa for replying.

Yes, I can feel the temperature being a bit high but not volcanic. Other than that I hesitate from upgrading my BIOS because I have read on many forums that it may lead to the non-functioning state of motherboard. I did not get what you implied by Debian and not Ubuntu. I can boot using live ubuntu usb. Or do you mean something else?

Pure Debian. @gacanepa meant what he said (I suppose you are a male human being, @gacanepa :blush:)

Ubuntu is based on Debian, it is Debian’s fork, derivative or whatever, but it’s not a pure Debian.

And this is it: https://www.debian.org/

And you can download it from here: https://www.debian.org/distrib/

Have you tried removing all power, including the CMOS battery, press the power button to purge all leftover power, and let the computer sit for 15-30 minutes? While the notebook is apart from removing the CMOS battery, this a good time to have a couple of cans of compressed air & blow the unit out really good, from all angles.

It may help to ensure the heatsink fins aren’t clogged, as well as the fan itself, though this may require removal to see it really good (if this is done, clean the components really good), and reapply some quality thermal paste to the areas where the original was, after cleaning with alcohol or nail polish remover & then ensuring all is dry, Only a pea or oat sized amount of paste is needed, more is too much & will lead to more overheating, less transfer to the heatsink will be the end result. Be careful when tightening the screws, run all until into the head contacts the surface & then finish tightening in a criss cross pattern, this prevents warpage of the heatsink & internal components.

By the time you’re finished with this, it’ll be time to plug the CMOS battery connector back on, or pop it back in place.

Hopefully this will solve your issue, if it’s heat buildup only. Any worse, there’s a motherboard issue to address.

Like @gacanepa stated, it’s helpful to boot from a live Debian ISO to see if the issue duplicates itself, or if any sensors can be read using the utilities within the menu.

Cat

Just did that a few days ago! Urgh!!! :skull:

Removing the CMOS battery and fiddling with jumpers didn’t help in my case. I had a guy from an IT store/service who couldn’t do anything so I tried to upgrade BIOS and now I only have the BIOS producer logo.

Any suggestions how to fix this?

Thanks