Error: Connection activation failed

Hello Friends

I am using cent os 7 and I want to configure network bridge through nmcli.

here is what I done

nmcli con add type bridge con-name nm-bridge ifname bridge
nmcli con modify nm-bridge ipv4.addresses ‘’
nmcli con modify nm-bridge ipv4.gateway ‘’
nmcli con modify nm-bridge ipv4.method manual
nmcli con add type bridge-slave con-name br0-port1 ifname enp2s0 master bridge

brctl show output like this

bridge name bridge id STP enabled interfaces
bridge 8000.000000000000 yes

nmcli connection up br0-port1

Error: Connection activation failed: Connection ‘br0-port1’ is not available on the device enp2s0 at this time.

ip link shows following

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
link/ether 00:1d:ba:00:97:40 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT qlen 1000
link/ether 00:21:5d:02:45:30 brd ff:ff:ff:ff:ff:ff
4: bridge: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN mode DEFAULT
link/ether d6:fe:f7:5b:91:af brd ff:ff:ff:ff:ff:ff

please help regarding this if any one has idea what’s wrong

In centos 6, I have read that network manager should be disable for bridging, hope so that be the case with centos 7 too.

Hi rai_nagendra,

Thanks for your valuable suggestion.

It was problem of network manager.

Thanks for help.