LinuxSay - A Discussion Forum for Linux Enthusiasts

Get Linksys AE1200 wifi usb to work on fedora

I have been trying to get this usb adapter to work on my Fedora 22 laptop, and I have had no success.

 # lsusb

ID 13b1:0039 Linksys AE1200 802.11bgn Wireless Adapter [Broadcom BCM43235]

I have tried linksys website but there is no drivers which isn’t a surprise, there are rearly and drivers for linux. I have also search the web for anything that would help and came across a way to install on Ubuntu but it doesn’t work on fedora.
any help to get this adapter to work would be most helpful.

thanks

  1. First download the drivers using following wget command and unpack it.

wget http://wikidevi.com/files/Drivers/Broadcom/bcmwl_4323x.zip

  1. Go the extracted folder bcmwl_4323x/xp/ and run the following commands.

cd /bcmwl_4323x/xp

ndiswrapper -i bcmwlhigh5.inf

modprobe ndiswrapper

ndiswrapper -l yielded:

3. After that, reboot the machine, If Wireless doesn't work, you need to add **ndiswrapper** to your **/etc/modules** to load at startup.
  1. Now you can following command to turn on Wireless…

modprobe -r ndiswrapper

modprobe ndiswrapper

I did everything you said and it recognises the linksys adapter and the light is on but sold not blinking and will not connect.

ndiswrapper -l yielded: (wouldn’t work. it just showed me ndiswrapper options)

ndiswrapper -l (worked)

                     bcmwlhigh5 : driver installed
                        device (13B1:0039) present 

When I try to connect it gives me the option of using the AE1200 but always fails
also could you tell me how to add ndiswrapper to /etc/modules
all i have in /etc/ is modules.conf, and modules-loaded.d