HP Desktop cannot boot from USB

Hi all!
I encountered a problem while installing Ubuntu in HP desktop. My HP machine boot from USB if it is in NTFS format (I can able to install windows based OS via USB). But when i boot from Linux USB, it does not show pen drive. I tried many booting software like unetboot, dd, YUMI, Linux Live USB & rufus. Again same problem. How to solve this?

Try to disable secure boot or fast boot and move USB to the first position in the boot priority menu.
If it still fails try to use another or a new USB drive, sometimes the problem can be with the USB drive.

I already did bro. Since same problem.It shows when pen drive is in NTFS file system. But not FAT32 file system. Usually linux usb keys are all FAT32 file systems

Dear Buvanesh

I think Plop Boot Manager will help you. What you need to do is just download iso image and write it in a cd. Then boot from cd. Keep the bootable usb connected (which contain ubuntu). When you boot from cd you it will give you an opportunity to boot from usb.

Find Plop Boot Manager here.

https://www.plop.at/en/bootmanager/plpbt.bin.html
https://www.plop.at/en/bootmanager/download.html

Think it will help you. It had helped me where I was unable to install win 7 from usb in a older desktop.

Regards
Jagamohan

1 Like

I already tried Plop too.
When i enter into USB via Plop, at the time window struck & no action happened