Installing KVM virtual machine hangs at “connecting to graphical console for guest”

This question is posted on superuser site (http://superuser.com/questions/956985/installing-kvm-virtual-machine-hangs-at-connecting-to-graphical-console-for-gue) first, but no any answer. So I repost it here, any help is appreicated!

I am using KVM to install a virtual machine on RHEL 7.0, but the installing hangs, and displays “connecting to graphical console for guest”:

enter image description here

The terminal log is like this:

[167804.496139] device vnet0 entered promiscuous mode
[167804.504108] virbr0: port 1(vnet0) entered listening state
[167804.510337] virbr0: port 1(vnet0) entered listening state
[167806.516029] virbr0: port 1(vnet0) entered learning state
[167808.522583] virbr0: topology change detected, propagating
[167808.528783] virbr0: port 1(vnet0) entered forwarding state
[167869.350584] kvm [87961]: vcpu0 disabled perfctr wrmsr: 0xc1 data 0xffff

After grep the kvm process, I try to use pstack pid:

[root@dhb5 ~]# pstack 87961
Thread 3 (Thread 0x7f7a8fbc1700 (LWP 87967)):
#0  0x00007f7a9811e4c7 in ioctl () from /lib64/libc.so.6
#1  0x00007f7a9d60c555 in kvm_vcpu_ioctl ()
#2  0x00007f7a9d60c66c in kvm_cpu_exec ()
#3  0x00007f7a9d5c0d95 in qemu_kvm_cpu_thread_fn ()
#4  0x00007f7a9b41bdf3 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f7a981273dd in clone () from /lib64/libc.so.6
Thread 2 (Thread 0x7f7a8ddff700 (LWP 87970)):
#0  0x00007f7a9811ce0d in poll () from /lib64/libc.so.6
#1  0x00007f7a98e01c37 in red_worker_main () from /lib64/libspice-server.so.1
#2  0x00007f7a9b41bdf3 in start_thread () from /lib64/libpthread.so.0
#3  0x00007f7a981273dd in clone () from /lib64/libc.so.6
Thread 1 (Thread 0x7f7a9d38ea40 (LWP 87961)):
#0  0x00007f7a9811ce0d in poll () from /lib64/libc.so.6
#1  0x00007f7a9d554a66 in main_loop_wait ()
#2  0x00007f7a9d47ae50 in main ()

It seems the process is blocked.

Could anyone give some clues about this issue? Thanks very much!