LinuxSay - A Discussion Forum for Linux Enthusiasts

Is there any way to run fsck for /usr File System (Without rebooting)?

After patching Rebooted the server but it went to Maintenance mode. Error was to run fsck manually for /usr FS. Unfortunatly I didnt have time to do it.So I used fastboot mode to skip the fsck check.Later am unable to run fsck against mounted /usr. Even tried lazy umount and ran fsck for the lv but still its throws error FS in Use.
Any trick or idea would be helpful.
Thanks.

Did you checked disk is unmounted or not after unmounting it

try these steps

#unmount -l /usr

#df -h —> make sure disk is unmounted

Run the below command for dry run to check the fs issues without modifying them

#fsck -nvf /dev/mapper/VolGrp-xxxx 

for modifying filesystem for making changes

#fsck -yvf /dev/mapper/VolGrp-xxxx

if you are still facing the issue share the screen shot of the error message

1 Like

Hi Raghuu,

I tried the steps you have asked but still unable to perform fsck.

# df -h /usr
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      1.9G  578M  1.3G  32% /

#fsck -yvf /dev/mapper/VolGroup00-LogVol04
fsck from util-linux-ng 2.17.2
e2fsck 1.41.12 (17-May-2010)
/dev/mapper/VolGroup00-LogVol04 is in use.
e2fsck: Cannot continue, aborting.
1 Like

someone managed to find an answer? OP, did you? please come back with updates if you did or anyone else who found an answer to this question. thanks!