Shutdown option is not working in Ubuntu after installing Cairo-dock

In my Ubuntu 14.04 PC, Ubuntu native shutdown option is not working after installing Cairo-dock. But i am able to shutdown via Cairo-dock shutdown option. I face this same problem in Ubuntu 12.10 version also. This is a bug? any Ubuntu experienced users here? How to solve this?

1 Like

NOTE: You shouldn’t be using unsupported versions of Ubuntu. Or indeed, any other distro. It reached end of life in May 2014. Be careful!

Edit: I dont’ think the “Cairo thing” is a bug. I had the same ‘problem’ but I learned to live with it.

1 Like

@Buvanesh_Kumar
I faced the same thing in Debian 7.0.6 (perhaps). I made a small shell script and put symbolic link in my docky.

Since then I haven’t looked back.

Well Debian 8 till now have no such issue.

1 Like

@Avi
If you don’t mind, share the script
It’s useful for me

Ahh @Buvanesh_Kumar,
It is a very simple script.

Complete it in two stage.

  • Create a file named ‘shutdown’ and populate it with below content

#!/bin/bash
sudo shutdown -h now

  • Create another file named ‘shutdown.desktop’ and put it preferably in the same folder where script shutdown is. Populate it with the below data and Replace /…/path/to/script/shutdown from the below content with your original path where script shutdown is.

#!/usr/bin/env xdg-open
[Desktop Entry]
Encoding=UTF-8
Name=shutdown
Comment=shutdown the system
Type=Application
Terminal=true
Exec=/…/path/to/script/shutdown
#Icon=/path/to/icon
StartupNotify=true
Categories=script;

Now put shutdown.desktop file anywhere on your desktop/docky. Double click it and your done! Let me know if any issue.

1 Like

@Avi
I receive following issue

When I click on shutdown.desktop it says “There was an error launching the application.”. I have checked all the permissions and path of the shutdown script. Please let me know where the problem is. I have trouble shutting down my laptop properly. It gets stuck in shutdown reboot loop. Also I am not able to detect if my CPU fan is working properly. Please help, I using Ubuntu 14.04.02.

Thanks!

@Buvanesh_Kumar @eralbert9191

Ubuntu implements it differently.
I have modified the shutdown.desktop code. Please use this code.

Also chmod 755 shutdown.desktop. Alternatively right click on shutdown.desktop icon and goto Properties >> Permissions >> check-mark “Allow executing file as program”.

and let me know if you were successful or not?

1 Like

@Buvanesh_Kumar
@eralbert9191

take some time to answer if this worked for you or not?

1 Like

@Avi
I change executable in script properties menu, Now it’s works fine.
But is it possible shutdown through the native shutdown option?

No it seems there is a bug, even i faced the same in Debian 7.

You may also define a key combination to shutdown under

Settings >> Keyboard >> shortcuts …

@Buvanesh_Kumar

1 Like