LinuxSay - A Discussion Forum for Linux Enthusiasts

Trouble to convert file system from ext3 to ext4

Hello,

We are planning to convert our SAN storage luns from ext3 file system to ext4 file system. For that, I am trying to convert it on test machine. I have been refer some google docs to convert file system and it successfully convert but I am not able to create any files or directories on that mounted point.

This mount point is shows " mkdir: cannot create directory `zz’: Read-only file system ".

After that I execute " mount -o remount,rw /dev/xvdc /abc/ " command but facing same error.
Any can tell me any command or solution for same error.

PFA for error screenshot images.

Regards,

Rajesh Kathar

Is any know solution for above error ???
Waiting for your reply.

Hi,

For converting ext3 to ext4 you can use mkfs command

What i know syntax is mkfs.ext4 /dev/xxx

Thanks

@chetankapoor321

As I mentioned above, This is a SAN storage. I have to convert these file system without data loss.

@rajeshkathar

Hi once you enable the ext4 features run the fsck for checking the filesystem

# tune2fs -O extents,uninit_bg,dir_index /dev/xvdc

#fsck.ext4 -yfD /dev/xvdc

here -D parameter will enable the “dir_index” option by rebuilding directory index

and reboot the server and also edit the /etc/fstab and replace ext3 with ext4 and mount the file system befor reboot