Ubuntu 14.04 not loading desktop environment

I just re-installed my Ubuntu 14.04 64-bit and it worked well. But after updating and upgrading by running the commands:

apt-get update and apt-get upgrade the system is now not working after i rebooted it.

After booting it only shows the login interface, when i feed in my password and click enter it does not load the desktop environment, shows a black screen, then a blue screen and stops there.

I have searched on the Internet but can not get an response that is helping me.


Once look at the below link it may help you


Try pressing Ctrl + Alt + F2 and then login again if needed. After that type startx and let us know what happens.

I have tried all these steps but non is working so, i just had to reinstall it.

It has failed to work after pressing Ctrl + Alt + F2 and then login in, running startx.

Sorry to hear that. I hope that everything is working normally now

Yes, thanks too for trying to help i appreciate that.

Just try to install ubuntu-desktop from commandline

sudo apt-get install ubuntu-desktop

i just need to clarify the doubt, if i re install the ubuntu 14.04 does the data gets afftected, because due to some system packages got deleted , its not booing. can i re install the uduntu 14.04 using the reinstall option with the datas ???

I always suggest better take backup of important files before doing a upgrade…:smile:

1 Like

That’s a good one Ravi! And very important. Unfortunatelly, I learned it the hard way too! :smile:

1 Like

running sudo apt-get install ubuntu-desktop did not work either