Unable to install VLC on RHEL 7

Hello everyone. I am a new learner of Linux. Right now i am trying to install VLC. Despite trying the solutions on superuse.com stackexchange.com and tecmint.com i am not able to install VLC on my system. I am providing an image to help you undertand the problem.

any links with latest information will do the job.



Install the required dependencies, you will get the list of dependencies after running below command

yum --skip-broken install vlc

these are epel and nux packages as at is showing at the end of the image. But i cant find them anywhere. Can you give me the latest packages for RHEL 7 links.

Go through the below below link if you face any issues just post here.


the highlighted are the results from the links that are shown at the link you provided. And i already tried this solution before posting the question here.

oh you already tried ok, once check whether both the repositories exists or not

#yum repolist 

and also remove those repositories and intall them again and link provided for epel repository in the article is not working so try another link to configure epel repository.

also check those repositories are enabled or not by editing /etc/yum.repo.d/epel.repo and /etc/yum.repo.d/nux.repo

enabled=1  (if enabled =0 then change to 1)

for reinstalling repositories just remove the existing repos by using rpm

#rpm -ev epel-release***


#rpm -ev nux-desk****

please take a look at the image. It shows that nux and epel are installed but when i am trying to uninstall it then it says that these repos are not installed.

while removing you should mention the proper name of the repository, any how try the below command to check the availability of vlc

# yum --enablerepo=nux-dextop info vlc

if it is available the install it

# yum --enable-repo=nux-dextop install vlc
1 Like